LiquidSky is proud to announce our alpha Mac client! LiquidSky for Mac will work on all Mac devices that have OS 10.8 or higher (Mountain Lion or higher).

Please remember that this is an alpha and will be prone to bugs. Let us know of any bugs you may encounter in our subreddit or in the comments below.

You can download the alpha client here.